[FSO] First steps

Joel Newkirk freerunner at newkirk.us
Wed Nov 19 21:57:03 CET 2008

On Wed, 19 Nov 2008 17:10:00 +0100, julien cubizolles
<j.cubizolles at free.fr> wrote:
> I just installed FSO and I'm quite happy with it : it seems the most
> reponsive distribution I have yet used. I still have some questions :
> Addressbook : Is there a way to import a former qtopia sqlite file ? I
> read some discussions inconclusive about it, is there some advances ?
> Calendar : openmoko-calendar2 isn't available in repositories. What can
> I use ? I

I don't have anything for you on these.

> GPS : do I need to click the map icon in zhone to powerup the antenna
> and use it with tangogps ? What are the three upper buttons supposed to
> do in the Zone gps application ? The first one displays
> latitude/longitude... (right now it displays N/A but I'm inside...)
> The second and third one open some window with obviously resolution and
> colors issues.

You can just fire up Tango and frameworkd will activate the GPS for it. 
The other two tabs in zhone (from memory - I'm running SHR right now) are:
an itemized list of satellites it's seeing, and a polar graph on which it
plots satellites.  (so at the start they're blank and a dartboard,

> Power Management settings: The settings from the wrench menu in illume
> don't seem to have any effect : the phone dims + blanks + locks after a
> minute or so even I set the blank time to off and doesn't suspend even
> though the suspend time after blank is 1s.

I think frameworkd handles power management, not illume.

> Suspend : according to the wiki, you need to press the power button for
> 2 s to suspend the phone. It doesn't work for me, just powers it off
> after 7-8 s.
> Sound : What's the best way to adjust the sound level ? I guess there's
> still no GUI for that. I've tried playing with several .state files
> during my first tries with other distributions but things change fast on
> this topic : what is the control to adjust ?
> Several applications from the Home menu (terminal, Htop for instance)
> won't start.

You can try changing /usr/share/applications/htop.desktop to exec
"openmoko-terminal2 htop", or install xterm and exec "xterm -e htop". (I've
done the latter)  What else isn't starting?

> I'm running :
> fso-image-om-gta02.jffs2

Just a note - at different times, the file above may in fact be different
images.  Today, it's the image from November 14th, for instance, but if a
new image were posted tomorrow it'd probably be a copy of tomorrow's image.
So try to note the date (if you used wget to download it probably preserved
the date) or pick out the newest of the 'long-named' images for download.
(It could also be from unstable vis testing, named the same)

The files below are both from October 5th, you might want the newest ones,
from November 7th.  (this might fix your suspend)


> uImage-2.6.24+r8
> +gitr968c41d0c32099d78927849a71e2ef3143cc05e7-r8-om-gta02.bin
> modules-2.6.24+r8
> +gitr968c41d0c32099d78927849a71e2ef3143cc05e7-r8-om-gta02.tgz

More information about the community mailing list