Zhone doesn't show my contacts and messages after restart

Paul Fertser fercerpav at gmail.com
Mon Nov 24 21:10:33 CET 2008


"Michael 'Mickey' Lauer" <mickey at openmoko.org> writes:
> Am Monday 24 November 2008 13:33:54 schrieb Paul Fertser:
>> I think i know what happens. If i restart Zhone without restarting
>> frameworkd it never receives ReadyStatus signal from
>> org.freesmartphone.GSM.SIM because sim was ready long ago it
>> started.
> This should no longer be a problem as nowadays, if the last GSM user vanishes 
> from the bus, the GSM resource (hence the modem) gets shutdown completely.

Yes, moreover after any network status change Zhone will try to reread
the contacts and messages lists. But the problem is that
org.freesmartphone.GSM.SIM.GetSimReady return 0 after Zhone
restart. According to log the modem doesn't send a %CSTAT status,
though it was resetted by ATZ and answered OK on AT%CSTAT=1 request.

I can send a log that shows that after a minute after ATZ the modem
still didn't send a %CSTAT report. It didn't send it later as well (or
else the icons in Zhone would have become highlighted).

As the exact documentation on %CSTAT is unavailable (thank you, TI), i
looked it up in Enfora's. It says that the %CSTAT codes will be
delivered only after power on. If it is really the case with calypso
it is no surprise that we never get SimReady signal as we don't
power-cycle the modem (ATZ seems to be not equivalent, and we can't do
$RESET). So it seems that %CSTAT should be avoided altogether...

Hope this helps.

Good luck!
Be free, use free (http://www.gnu.org/philosophy/free-sw.html) software!
mailto:fercerpav at gmail.com

More information about the community mailing list