Freerunner's GSM Calypso Modem Firmware Upgrade...

William Kenworthy billk at
Tue Nov 25 02:01:13 CET 2008

ok, replying to myself as it may help others:

First off, when I eventually got 2008.9 registered, an SMS that was sent
some hours before came in (that perennial 2008.x problem :(  I surmise
that this was the reason I couldnt get it to flash (e.g., SMS waiting)

Next I shut down X on 2008.9 and was able to flash the gsm chip with the
following config:
Vodafone (128K) SIM inserted and registered (nothing in guide about sim
shutdown X
no apps running that linked to the tty
did *NOT* issue power off/on commands as the guide specifies
Used guide from that point on.
Worked without problems.

I have now done 3 reboots - PIN dialog came up first time, everytime so
far ... would need a few more tries before I could put it down to luck
or cured, but three in a row has almost never happened before now.

A test sms sent to the phone after it had been suspended for ~10 minutes
woke it up but did not indicate message received or similar.  On
resuspending for a few seconds and manually unsuspending, the sms
received dialog came up.  This would indicate this problem (lost,
unannounced SMS messages) is still there, though the usual symptom is
nothing received until after a full reboot.


On Mon, 2008-11-24 at 21:44 +0900, William Kenworthy wrote:
> Just tried this a dozen times.  It always hangs at 
> "Bootloader: (reset target)"
> I log into the second termial as stated, issue "s3c24xx-gpio b7=1"
> and wait ...wait ...wait ...
> Used the reccomended rootfs etc.
> Gone back to 2008.9 and see if gsm is still there ... it is!
> BillK
> On Tue, 2008-11-18 at 20:07 +0100, "Marco Trevisan (Treviño)" wrote:
> > This is just to notify the community users who don't read the devel
> > list: Joerg, Dieter and Werner set up some tools to upgrade the firmware
> > of the GSM Modem of the Frerunner (TI Calypso) to a newer image [1].
> > 
> > If you're affected by the infamous #666 - No SIM found - bug, you could
> > try to upgrade your phone's firmware using the tools provided by OM guys
> > to the moko10 (beta2) version [2].
> > 
> > Look at the wiki [3] for more help and keep us (and the Devs) informed!
> > 
> > [1]
> > [2] They're closed, but it's not an OM fault, and I think we should
> >     thank them for this too.
> > [3]
> > 
William Kenworthy <billk at>
Home in Perth!

More information about the community mailing list