kismet on freerunner

Joseph Reeves iknowjoseph at
Wed Nov 26 14:27:30 CET 2008

Which would be why NeoPwn comes with a compatible USB wifi adapter.


2008/11/26 Graeme Gregory <graeme at>:
> On Wed, 2008-11-26 at 14:18 +0100, jhig wrote:
>> hi,
>> i don't know if this was allready a topic here:
>> does kismet run on freerunner?
>> i installed debian and the kismet package.
>> now i have to insert the right source into the kismet.conf file.
>> i tried
>> source=ath5k,eth0,wifi
>> but all i get is:
>> debian-gta02:~/progs# kismet_server
>> Suid priv-dropping disabled.  This may not be secure.
>> No specific sources given to be enabled, all will be enabled.
>> Non-RFMon VAPs will be destroyed on multi-vap interfaces (ie, madwifi-ng)
>> Enabling channel hopping.
>> Enabling channel splitting.
>> NOTICE: Disabling channel hopping, no enabled sources are able to change
>> channel.
>> Source 0 (wifi): Enabling monitor mode for ath5k source interface eth0 channel
>> 6...
>> FATAL: Failed to set monitor mode: Invalid argument.  This usually means your
>> drivers either do not support monitor mode, or use a different mechanism for
>> getting to it.  Make sure you have a version of your drivers that support
>> monitor mode, and consult the troubleshooting section of the README.
> I think that message is self explanatory. The drivers don't support
> monitor mode so you cant use kismet.
> Graeme (XorA)
> _______________________________________________
> Openmoko community mailing list
> community at

More information about the community mailing list