[Debian] TSLIB_TSDEVICE no longer getting set

Christopher J. White chris at grierwhite.com
Sun Nov 30 03:09:02 CET 2008

On Sat, 2008-11-29 at 21:53 +0000, Joachim Breitner wrote:
> Hi Christopher,
> Am Samstag, den 29.11.2008, 16:18 +0000 schrieb Christopher J. White:
> > I've been trying to get gestikk [1] working, a mouse-gestures program
> > that turns mouse gestures into keystrokes at the window manager level.
> > This seems ideal for finger gestures to do things like scrolling,
> > paging, etc in a generic fashion.
> Nice program. What are you going to use as a toggle? AUX-Key?

Yeah, it's looking promising.  I'm not quite sure yet how to integrate
it.  I've managed to get it working with the standard Xorg distribution,
but not Xglamo as it require Xkb, which Xglamo doesn't currently
support.  (anyone interested, I can send you pointers to what I've got
working....not quite ready though).

At a basic stage, I can define a finger gesture and map it to a
keystroke such as "a".  So far the mouse events are simultaneously
passed to the underlying application.  For example, passing a simple
"stroke up" will be recognized by gestikk, but also passed to the xterm
that has focus and thus will select and drag across the xterm window.
Not ideal.

Ideally it would always be active in a smart mode.  I'm thinking about
trying to restrict it such that if there is no movement after the
initial "click", than it is *not* a gesture.  If there is immediate
motion, capture the entire mouse motion as a gesture and attempt not to
pass it along to the underlying application.  We'll have to see how
easily this is achieved.  

It may work best enabled for some apps but not others. 

At worst, I'll use the AUX-key or something like that as a trigger to
enable gesture recognition.

> > After working through package dependencies, and building a needed python
> > module, I got it fulling installed and actually managed to get it to run
> > and put it's icon in the tray.  Unfortunately, it requires
> > right-click...i don't have the right-click tslib patch installed (yet),
> > so I reran the program in a mode that allows configuration.  
> > 
> > As soon as I did that, I seemed to lose pointer input.  /etc/init.d/nodm
> > restart, reboot, all have no effect.
> > 
> > I have traced it down to TSLIB_TSDEVICE no longer getting set.  If I
> > manually export this set properly, and do startx, it works, I get my
> > pointer back.
> > 
> > I am running X as a normal user, but the same happens when reverting
> > back to root as well.
> > 
> > So, what happened?  I can't figure out how /etc/init.d/nodm is supposed
> > to setup environment variables that tslib needs. 
> AFAIR, it is not necessary anymore to set this variable,
> if /etc/X11/xorg.conf and/or the udev rules are set up correctly – did
> you by any chance modify that?

I was running Xglamo at the time, so I had modified xorg.conf to point
to Xglamo as the display device.  However, something happened that
screwed that up, both for Xglamo as well as fbdev.  Right now neither
will work.

In fact, it's rather strange.  If I start xinit manually after setting

$ export TSLIB_TSDEVICE=/dev/input/event1
$ /usr/bin/xinit /etc/X11/Xsession

However, when I run it in a fashion similar to /etc/init.d/nodm, it

$ /bin/su --login --command "/usr/bin/xinit /etc/X11/Xsession" root

This is despite putting the export command in .bashrc and verifying that
it's set.  I even tried verifying that it was getting TSLIB_TSDEVICE:

$  /bin/su --login --command "printenv" root

However, it still fails to work.

I removed and then reinstalled xserver-xglamo, and the error messages
changed, but it still does not work.


More information about the community mailing list