[Debian] TSLIB_TSDEVICE no longer getting set

Joachim Breitner nomeata at debian.org
Sun Nov 30 14:14:59 CET 2008


Am Sonntag, den 30.11.2008, 02:09 +0000 schrieb Christopher J. White:
> > AFAIR, it is not necessary anymore to set this variable,
> > if /etc/X11/xorg.conf and/or the udev rules are set up correctly – did
> > you by any chance modify that?
> I was running Xglamo at the time, so I had modified xorg.conf to point
> to Xglamo as the display device.

I thought Xglamo does not need any xorg.conf? But maybe that’s just

> However, something happened that
> screwed that up, both for Xglamo as well as fbdev.  Right now neither
> will work.
> In fact, it's rather strange.  If I start xinit manually after setting
> TSLIB_TSDEVICE, it works:
> $ export TSLIB_TSDEVICE=/dev/input/event1
> $ /usr/bin/xinit /etc/X11/Xsession
> However, when I run it in a fashion similar to /etc/init.d/nodm, it
> fails:
> $ /bin/su --login --command "/usr/bin/xinit /etc/X11/Xsession" root
> This is despite putting the export command in .bashrc and verifying that
> it's set.  I even tried verifying that it was getting TSLIB_TSDEVICE:
> $  /bin/su --login --command "printenv" root
> [...]
> TSLIB_TSDEVICE=/dev/input/event1
> However, it still fails to work.
> I removed and then reinstalled xserver-xglamo, and the error messages
> changed, but it still does not work.

This is the original xorg.conf, as installed by the install.sh script:
# Xorg confiugration for an Openmoko FreeRunner
Section "InputDevice"
	Identifier	"Configured Touchscreen"
	Driver		"tslib"
	Option		"CorePointer"		"true"
	Option		"SendCoreEvents"	"true"
	Option		"TslibDevice"		"/dev/input/event1"
	Option		"Protocol"		"Auto"
	Option		"Width"			"480"
	Option		"Height"		"640"

Section "Device"
	Identifier	"Configured Video Device"
	Driver		"fbdev"

You still have problems with that file? Anything interesting in the X log file?


Joachim "nomeata" Breitner
Debian Developer
  nomeata at debian.org | ICQ# 74513189 | GPG-Keyid: 4743206C
  JID: nomeata at joachim-breitner.de | http://people.debian.org/~nomeata
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Dies ist ein digital signierter Nachrichtenteil
Url : http://lists.openmoko.org/pipermail/community/attachments/20081130/2e2c973c/attachment.pgp 

More information about the community mailing list