[Debian] TSLIB_TSDEVICE no longer getting set

Christopher J. White chris at grierwhite.com
Sun Nov 30 16:23:28 CET 2008

On Sun, 2008-11-30 at 14:14 +0100, Joachim Breitner wrote:
> Hi,
> Am Sonntag, den 30.11.2008, 02:09 +0000 schrieb Christopher J. White:
> > > AFAIR, it is not necessary anymore to set this variable,
> > > if /etc/X11/xorg.conf and/or the udev rules are set up correctly – did
> > > you by any chance modify that?
> > 
> > I was running Xglamo at the time, so I had modified xorg.conf to point
> > to Xglamo as the display device.
> I thought Xglamo does not need any xorg.conf? But maybe that’s just
> rumors.

I had to change the Section "Device", Driver "fbdev" to Driver "Xglamo"
to make the switch to Xglamo, but I have also heard that Xglamo ignores
other config options, such as the "TslibDevice" option.  Supposedly
Xglamo is hardcoded to use TSLIB_TSDEVICE.

> This is the original xorg.conf, as installed by the install.sh script:
> ====================================================================
> # Xorg confiugration for an Openmoko FreeRunner
> Section "InputDevice"
> 	Identifier	"Configured Touchscreen"
> 	Driver		"tslib"
> 	Option		"CorePointer"		"true"
> 	Option		"SendCoreEvents"	"true"
> 	Option		"TslibDevice"		"/dev/input/event1"
> 	Option		"Protocol"		"Auto"
> 	Option		"Width"			"480"
> 	Option		"Height"		"640"
> EndSection
> Section "Device"
> 	Identifier	"Configured Video Device"
> 	Driver		"fbdev"
> EndSection
> ====================================================================

Yes, this is what my xorg.conf currently looks like, and no luck.  

Running just /usr/bin/xinit or /usr/bin/startx as root, I get:

X.Org X Server 1.4.2
Release Date: 11 June 2008
X Protocol Version 11, Revision 0
Build Operating System: Linux Debian (xorg-server 2:1.4.2-9)
Current Operating System: Linux debian-gta02 2.6.24-20081103.git7172ec57
#1 PREEMPT Wed Nov 12 23:54:02 UTC 2008 armv4tl
Build Date: 18 November 2008  01:48:08PM
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Nov 30 09:17:54 2008
(==) Using config file: "/etc/X11/xorg.conf"
No raw modules loaded.
ts_config failed
(EE) PreInit returned NULL for "Configured Touchscreen using tslib"
[config/hal] couldn't initialise context: (null) ((null))

X starts up, but no pointer action.

So...I took the next step and started defining all the TSLIB variables:

$ export TSLIB_TSDEVICE=/dev/input/event1
$ export TSLIB_CONFFILE=/etc/ts.conf
$ /usr/bin/xinit
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Nov 30 09:30:47 2008
(==) Using config file: "/etc/X11/xorg.conf"
[config/hal] couldn't initialise context: (null) ((null))

And *now* I get successful pointer action.

Now that I figured this out, I can put those two exports into my .bashrc
for root, but the same trick for my normal user doesn't work.  Trying to
start xinit or startx manually gives permission errors
on /var/log/Xorg.log.0.

So this tells me something changed that used to set the TSLIB vars
before starting Xserver.  Can you grep for TSLIB for all files
in /etc/X11 and below and see if you see it there anywhere?


More information about the community mailing list