[FDOM 080927] Modem jokes on SIM entries

Dan Staley dlstal2 at uky.edu
Wed Oct 1 16:25:32 CEST 2008

I also have this problem.  I'm glad I'm not the only one.  I was worried
my sim card reader broke.  (As the contacts were being imported
correctly before.

When I first boot up the phone, it connects to the network and can make
calls and suspend fine.  However, if I try to goto the contacts
application, it hangs up on "Loading Sim..." and after that I can no
longer make/receive calls or come back from suspend.

When this first started happening, I would goto the contacts and no
contacts would be loaded.  I thought this might be because of the
excessive amount of contacts I had on my sim card (250+).  So I went and
cleaned out quite a few of them.  After that, I tried again.  Now I get
the same outcome (no calls/suspend) and the "Loading Sim..." message
stays at the top, but I get a list of garbled and certainly not correct

Because of the garbled contacts, I wonder if the qtopia dialer got
upgraded and the new version does not split the data up correctly from
the sim card?  perhaps the delimeters are wrong?

I'm using an ATnT fireball sim card and it has worked fine before this.

Anyone have any idea?

-Dan Staley

On Wed, 2008-10-01 at 03:21 -0400, madis wrote:
> Hi David and Linus,
> I have the same problem...
> After registering if I try to open the phone book I see only message
> "Loading Sim..."
> I can't see my phone book content in Sim and my FR behaves very
> strangely also.
> I can't receive calls if somebody calls. My FR rings, but I am unable
> to press the answer button, the touch screen is not responding.
> The screen itself is ok, because all other times it works.
> I can't make any phone calls, my FR says it's dialing the number,
> but nothing happens in reality.
> Regards,
> Madis
> David Samblas wrote:
> > Hi linus,
> > the only modification done vs the OM 2008.9 regarding gsm is the
> > addition of the
> > http://www.angstrom-distribution.org/feeds/2008/ipk/glibc/armv4t/base/gsm0710muxd_0.9.1+r0-gitr3ff86b129640b647ccba3d86eb243d864671b039-r0_armv4t.ipk
> > packages and some configuration in the /etc/X11/Xsession.d/89qtopia to
> > make it work.
> > The rest is as is in the 2008.9 so you I suppose you can debug as you
> > where in 2008.9 downloading the source code of Contact if you want.
> >
> > BTW I have no knowlege about any one else having this issue.
> >
> > Next FDOM release will come from a svn repository that will keep track
> > of the modifications  we have done to the 2008.X to become an FDOM, then
> > you will see from where a packages come(OM , angstrom or other
> > repositories or direct download from OM projects or from anywhere else)
> > I hope this helps to those asking from the souce code of FDOM.
> >
> > Regards
> > David Samblas
> > El mar, 30-09-2008 a las 07:03 +0100, Linus Gasser escribió:
> >
> >> Hi list,
> >>
> >> I'm running the latest FDOM (20080927) but still have a very annoying
> >> problem: my SIM-card is not read with regard to the address entries. If
> >> I go to the "Contacts", there is only written "Loading SIM" on top, but
> >> nothing shows. IIRC, this was no problem in ASU_0807.
> >>
> >> Is there any way I can debug that to see where it stops? With the SIM
> >> not being loaded, I can neither call, nor receive calls, nor suspend. Or
> >> shall I do a binary search to see whether it's a special entry that
> >> causes this?
> >>
> >> Thank you for any hint you may give me,
> >>
> >> Linus
> >>
> >>
> >> _______________________________________________
> >> Openmoko community mailing list
> >> community at lists.openmoko.org
> >> http://lists.openmoko.org/mailman/listinfo/community
> >>
> >
> >
> > _______________________________________________
> > Openmoko community mailing list
> > community at lists.openmoko.org
> > http://lists.openmoko.org/mailman/listinfo/community
> >

More information about the community mailing list