[FDOM 080927] Modem jokes on SIM entries

Devendra Gera gera at theoldmonk.net
Wed Oct 1 17:00:49 CEST 2008

On Wed, 01 Oct 2008, Dan Staley wrote:

> I also have this problem.  I'm glad I'm not the only one.  I was worried
> my sim card reader broke.  (As the contacts were being imported
> correctly before.
> When I first boot up the phone, it connects to the network and can make
> calls and suspend fine.  However, if I try to goto the contacts
> application, it hangs up on "Loading Sim..." and after that I can no
> longer make/receive calls or come back from suspend.
> When this first started happening, I would goto the contacts and no
> contacts would be loaded.  I thought this might be because of the
> excessive amount of contacts I had on my sim card (250+).  So I went and
> cleaned out quite a few of them.  After that, I tried again.  Now I get
> the same outcome (no calls/suspend) and the "Loading Sim..." message
> stays at the top, but I get a list of garbled and certainly not correct
> contacts.
> Because of the garbled contacts, I wonder if the qtopia dialer got
> upgraded and the new version does not split the data up correctly from
> the sim card?  perhaps the delimeters are wrong?

I have similar problems, but the SIM contacts which are imported aren't
garbled at all. Some of them are missing for sure though.

The workaround that I earlier mentioned - not using the phone for some
time even after GSM registration - and avoiding reading the SIM contacts
at all seems to make the phone usable as a day phone (for a very twisted
value of usable - without contacts).


More information about the community mailing list