[2008.9]Debugging the FreeRunner Kernel?

Alastair Johnson alastair at truebox.co.uk
Fri Oct 3 16:11:35 CEST 2008

Arigead wrote:
> Alex Osborne wrote:
>> Helo Arigead,
>> Arigead wrote:
>>> Does anybody have an opinion 
>>> that it might not be the kernel? As it happens all the time for various 
>>> apps I'm assuming that it's something core.
>> When it locks up, does the device stop responding to ping over USB?  
>> That would indicate the whole kernel is getting messed up by the lock ups.
>>> Would the debug board enable me to get to the bottom 
>>> of this? 
>> It would probably help to some extent.  You could see the kernel 
>> messages over the serial console and potentially even inspect what the 
>> CPU is doing when it hangs over JTAG.  Although if it's a hardware 
>> fault, which seems likely if nobody else seems to be experiencing random 
>> lockups, I guess it could be really hard to diagnose even with the debug 
>> board.
>>> Will somebody 
>>> please reply so that I can tell it's got to the list
>> Your mails are getting to the list.  See for example:
>> http://kerneltrap.org/mailarchive/openmoko-community/2008/10/1/3465464
>> Cheers,
>> Alex
> Thanks Alex,
> I do think it's most likely a HW problem as it's happening in all the 
> Distros. Well I've not really tried with Qtopia to much, would prefer to 
> be using [ASU] or [FSO]. Having said that if I tried Qtopia and it locks 
> then it would suggest it's HW.
> Anyhow perhaps the only way to go is to get the development board. Even 
> if it is a HW problem it's locking the SW somewhere. I'll try Qtopia 
> over the weekend and try build a SW Image for the FR. I've never built 
> the entire system but I might try and see if I can put in a few 
> judicious Printf's. Problem with printf's or logging is that the code 
> might have passed the printf and lock 20 odd instructions later and 
> you'd not see the printout, depending on the implementation. I don't 
> know how logging is implemented but I'll have a look.
> Thanks again for getting back to me. Don't know whether to invest more 
> money in the debug board or try get a replacement. It is a challenge 
> though :-)

It might be worth trying rootfs on the uSD to see if the problem is with 
the internal flash. You may also be able to find someone near you who 
has a debug board.

More information about the community mailing list