FDOM and WiFi

Michael Shiloh michael at openmoko.org
Fri Oct 3 21:44:57 CEST 2008

At this point you can try manually configuring the wireless card:

iwconfig eth0 essid linksys

Does your network have an encryption key? How many letters? I think 
there is a bug that one letter keys don't work.

If your network has an encryption key, I think another bug requires that 
you set the key before the ID thus:

iwconfig eth0 key 123456789 essid linksys

Let me know if this works and we'll update the wiki accordingly


Vince M. Clark wrote:
>   Here is the output. I can see the access point but it is not connected 
> even though in Mofi the circle is orange next to the access point.
> root at om-gta02:~# iwconfig eth0
> eth0      AR6000 802.11g  ESSID:"" 
>           Mode:Managed  Bit Rate:1 Mb/s   Tx-Power=0 dBm   Sensitivity=0/3 
>           Retry:on  
>           Encryption key:off
>           Power Management:off
>           Link Quality:0/94  Signal level:-95 dBm  Noise level:-96 dBm
>           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
>           Tx excessive retries:0  Invalid misc:0   Missed beacon:0
> root at om-gta02:~# iwlist eth0 scan
> eth0      Scan completed :
>           Cell 01 - Address: 00:0F:66:D2:BB:41
>                     ESSID:"linksys"
>                     Mode:Master
>                     Frequency:2.437 GHz (Channel 6)
>                     Quality=15/94  Signal level=-80 dBm  Noise level=-95 dBm
>                     Encryption key:off
>                     Extra:bcn_int=100

More information about the community mailing list