QTextended 4.4.1

Franky Van Liedekerke liedekef at telenet.be
Sun Oct 5 18:02:35 CEST 2008

On Sun, 05 Oct 2008 18:27:01 +0530
Vibhav Sharma <khoonirobo at gmail.com> wrote:

> Paul wrote:
> > Hi,
> >
> > I just flashed QTextended 4.4.1. on my FR (becoming adventurous),
> > and it works quite well.
> >
> > Something I found:
> >
> > - pairing a Bluetooth device works well
> > - switching OFF the Bluetooth device makes the FR hang
> >
> > After removing the battery and rebooting:
> >
> > - switching ON the Bluetooth device makes the FR hang
> >
> > In both occasions, a small timer-clock starts revolving and at "14 
> > seconds" it stops and is determined to stay there.
> >
> >   
> Hi all,
> Not tried bluetooth, but been using QTextended since yesterday, and
> here are my observations:
> 1. On incoming call, ringtone is played from ear-phone instead of 
> speaker-phone. Media player also plays back using ear-phone.
>     * by ear-phone I mean the speaker where you put your ear to to 
> listen to other party in voice call and speaker-phone is the speaker
> on the side.
> 2. Power management can be a little erratic. I.e. I changed settings
> so that phone does not suspend even on battery (worked). Changed it
> to suspend again after 50s (did not work). Shutdown and restarted
> phone (suspending properly again).
> 3. Executing 'apm' from terminal earlier used to give battery
> status ... does not any longer. I'm assuming this is related to
> battery icon showing empty.
> 4. Wifi configuration worked perfectly from gui. Except for empty 
> 'resolv.conf', I vaguely remember seeing somewhere that have to do
> stuff to get that working. Will look into that. 'System Info' network
> showed wrong gateway (IP assigned to device instead of gateway IP).
> But configuration was correct according to 'ip route show' and it was 
> working ok.
> 5. Contact upload from vcf worked. For newbies: path is now 
> /opt/Trolltech/Qtopia/... instead of /opt/Nokia/Qtopia/... if you are 
> using the instructions from
> http://wiki.openmoko.org/wiki/Import_Vcf_Contacts . Will update wiki
> on this soon.
> 6. Phone UI freezes for some time (30s) sometimes (rarely). Not been 
> able to do any further analysis as to when / why / how.
> 7. Desperately need info on how mapping demo can be configured etc.
> Need to cache maps. It seems you can't move around / zoom.
> @Lorn
> any way we could provide you with debugging info / help that you
> require to get this working perfectly. If you could guide us to some
> links etc for the same.
> Would be much appreciated.
> If anybody has observed these issues in their setup / worked around 
> them, pointers would be appreciated.


I haven't had any issues with bluetooth or waking up from suspended for
a call (haven't tried sms before). However, my issues are:

- echo is back. With echo I mean when somebody else is calling you on
your freerunner and they hear everything they say themselves. This in
fact is so loud that the freerunner is unusable as a phone. Maybe that
alsa controls can help here, but I don't seem to be able to find the
alsa state files on qtextended.
- alarm doesn't sound on time when the phone is suspended. The phone
unsuspends right on time, but no alarm is played/shown (but it does
after a while if you keep the phone unsuspended). Probably this has to
do with the alarm already being overdue when the phone finishes
unsuspending. Being somebody who doesn't own a separate alarm clock,
this is a must-have function for me.

For the empty battery icon: install the latest webster kernel found at
http://moko.mwester.net/dl.html#kernels , this kernel fixes at least
that and maybe even the bluetooth issues.


More information about the community mailing list