microSD single ext2 or ext3 partition boot?

feywulf feywulf9 at yahoo.com
Mon Oct 6 03:49:56 CEST 2008


I'm a new Neo Freerunner user.  I got it a few weeks ago and signed up for service to use with it on Saturday.

When i first tried loading a distribution onto a microsd card, i hadn't yet read how to ssh into the phone, and tried setting one up by having it connected to my computer in a card reader.  That didn't work so well, and i still haven't figured out why.  I think it would be handy to be able to setup a microsd without booting into a different distribution in the flash memory and then using ssh to get in.

Then I updated my u-boot and flashed the phone using neotool to try out a few different distributions.  I still haven't decided on one.

After i found out how to ssh into the phone i was able to load qtopia 4.3.3 on the 512 microsd that came with the freerunner.  It works ok, though for some reason my ear piece speaker wasn't playing sound.  I tried qtextended 4.4.1 flashed on the phone and it works ok so far.  The ear piece speaker does function, but there is some GSM buzzing noise for the people on the other end.

Also I'd like to be able to get the phone setup so i can boot off of a microsd with a single ext2 or ext3 partition that takes up the entire microsd card.  Since the updated uboot works with ext2 partitions it should be possible to do.  Would this work?

setenv menu_9 Boot from microSD (ext2): setenv bootargs \${bootargs_base} rootfstype=ext2 root=/dev/mmcblk0p1 rootdelay=5 \${mtdparts} ro\; mmcinit\; ext2load mmc 1 0x32000000 \${sd_image_name}\; bootm 0x32000000

I'm thinking that the 0x32000000 might indicate an offset to where the partition starts when you have an 8mb vfat partition first.  Should it be changed to 0x0?

I haven't tried FSO or FDOM yet, but will be giving them a try soon.



More information about the community mailing list