[Om2008.8 - testing] - No soundcards found... (maybe problem with qi ?)

Benedikt Schindler BeniSchindler at gmx.de
Wed Oct 8 08:46:20 CEST 2008

Benedikt Schindler schrieb:
> Device: GTA02
> Distro: om2008.8
> version: unstable
> Last update/upgrade: today
> does someone know this problem:
> -----------------------------------------------
> root at om-gta02:~# opkg upgrade
> Configuring alsa-state
> System startup links for /etc/init.d/alsa-state already exist.
> /usr/sbin/alsactl: load_state:1327: No soundcards found...
> postinst script returned status 237
> Collected errors:
> * ERROR: alsa-state.postinst returned 237
> ------------------------------------------------


i am very busy at the moment so i hadn't had time to investigate this 
But yesterday i had two hours left, so i found a few things out.

I have a solution now ... maybe it's a problem with qi (also if i don't 
know, how the bootloader could have something to do with it) .... or 
maybe it's somethoing else
i don't realy know. so  i just describe all my steps and you could make 
your own opinion.


I installed qi a few weeks ago.
Everything was OK.

i run the freerunner into a total empty battery state. (so there was no 
regular shutdown)
i didn't had have a sound card anymore.

ASoC version 0.13.1
Only GTA01 hardware supported by ASoc driver

i thought it is a problem with the updates in the unstable/testing tree.
there where no other reports and no one could help me.
Because it is very unnormal for a bug to show up just by me,
i thought where is the differnce between my freerunner and most of the 
other freerunners out there.
And then i remebered that i had installed qi.
So i flashed U-Boot back to the freerunner.
And now the soundcard was back again.

ASoC version 0.13.1
wm8753: WM8753 Audio Codec 0.16
asoc: WM8753 HiFi <-> s3c24xx-i2s mapping ok
asoc: WM8753 Voice <-> Bluetooth mapping ok
Only GTA01 hardware supported by ASoc driver

so i thought that couldn't be and installed qi back.
everything was fine again, and sound card still worked.
i crashed the freerunner (sorry, i don't know how)

soundcard was gone again.
i reflashed the newest u-boot and there the soundcard was back again.
so i now stay by the u-boot image ;)


so i don't know how this could be.
But maybe the U-Boot is reseting the soundcard in some way, and qi 
didn't do that.

don't know, but i have a running freerunner again. ;)

c u all


More information about the community mailing list