[qtextended] problems with roaming

Cédric Berger cedric.berger74 at gmail.com
Wed Oct 8 11:18:31 CEST 2008

With 4.4.1 version I have problems when I have to switch GSM network.

-> looks like it switches correctly (automatic mode) at first.
Initialy registered on "SFR" (my provider), change to "Orange CH" was automatic.

1. Once it has switched to roaming network I hardly can select back
another. if I go to "Select operator" :
- sometimes it is stalled waiting for answer from modem
(or maybe it did not really ask, since several times -not always-, in
the log, the AT+COPS=? command was not even issued and GUI was waiting
the response)
- sometimes it says there was no operator found (response was
immediate, looks like it did not even try to search)
- when I can get to the list of available operators it fails selecting one :
 most of the time, it fails to register. Even if correct command
AT+COPS=1,"20810" (as I remember) was issued, there was no response of
operator selection in the logs.

2. Even if it stays in automatic mode, when I come back to a zone
where only initial operator "SFR" is available, it fails to switch
back and stays on (unavailable) "Orange CH".
Even rebooting did not solved the problem and I had to reboot on
another distro (qtopia 4.3.3) to switch operator.

(this morning, only after a reboot and several tries I could manually
select back the operator I wanted, from qtextended)

3. Once, it automaticaly switched to roaming network (and I indeed had
the little triangular icon indicating roaming), BUT it continued to
show incorrect label "SFR".
Even in "Call Network"->"Current status" it said "SFR", "registered
roaming"   (inconsistent, in fact it was roaming but it was "Orange
CH" that it was registered to).
(A chance that the icon showed me there was a problem... I would have
been charged a LOT calling from a roaming network instead of mine)

I do not know if this may be related to the "bouncing calypso" problem
(which it looks like have sometimes -not absolutly sure-).
Note that with 4.3.3 version (after AT commands for manual selection
were fixed about one month ago), roaming still works. (except simple
"Search mode" change command that never worked)

PS. not always easy to test, since it depends of network availability
where you are... and on monday -I knew only the day after- there was
even a country wide problem  on SFR network to add to the difficulty
to attribute responsability to erratic behaviours...

More information about the community mailing list