[Raster+FSO] Silent Zhone

joakim at verona.se joakim at verona.se
Thu Oct 9 01:03:18 CEST 2008

Joel Newkirk <freerunner at newkirk.us>

> Well I still get no sound with Zhone, calls are silent both ends, and it
> never rings.  I can play back audio with aplay and mplayer (wave, ogg,
> mp3), and Raster's alarm clock works.  If I manually invoke 'alsactl -f
> /usr/share/openmoko/scenarios/gsmhandset.state restore' while in a silent
> call, I get two-way sound.  But still no ringing, and of course manually
> calling alsactl whenever I'm lucky enough to notice that it's ringing so I
> can have a conversation is right out... ;)
> Can anybody suggest a solution?  I've been running this config for a few
> days now, and I'm kinda tired of not being able to use it as a phone.  I've
> tried running zhone by hand and watching its output: I see nothing but
> setup messages, IDLE/BUSY notes, and CALL STATUS. So what can I do to watch
> when it's attempting to use audio, and possibly see what's breaking?  And
> where is the ringer defined/controlled with Zhone?

It sounds similar to the problem I had getting ringing working with
zhone in Debian. look in the mailing list, but this is the essence:

cd /
ln -s /usr/share
this was due to a pkg problem in Debian. I dont know if it helps you.

also try playing the arkanoid sid tune with sidplay and see if that

> j
Joakim Verona

More information about the community mailing list