[Raster+FSO] Silent Zhone

Joel Newkirk freerunner at newkirk.us
Thu Oct 9 07:58:45 CEST 2008

On Thu, 09 Oct 2008 01:03:18 +0200, joakim at verona.se wrote:
> Joel Newkirk <freerunner at newkirk.us>
> writes:
>> Well I still get no sound with Zhone, calls are silent both ends, and it
>> never rings.  I can play back audio with aplay and mplayer (wave, ogg,
>> mp3), and Raster's alarm clock works.  If I manually invoke 'alsactl -f
>> /usr/share/openmoko/scenarios/gsmhandset.state restore' while in a
> silent
>> call, I get two-way sound.  But still no ringing, and of course manually
>> calling alsactl whenever I'm lucky enough to notice that it's ringing so

> It sounds similar to the problem I had getting ringing working with
> zhone in Debian. look in the mailing list, but this is the essence:
> cd /
> ln -s /usr/share
> this was due to a pkg problem in Debian. I dont know if it helps you.
> also try playing the arkanoid sid tune with sidplay and see if that
> works.

Well, I bricked it.  Reflashed Raster, brought it back where I'd had it,
and bricked it again.  then a third time running right now, without opkg
upgrade this time.  

So I haven't had a chance to worry about sound. :(

That link command is missing something, needs both target & link.

What arkanoid sid tune?


More information about the community mailing list