[Qtextended] Roadmap2 - invalid tar magic while installing

Nishit Dave stargazer.dave at gmail.com
Thu Oct 9 14:55:24 CEST 2008

On Thu, Oct 9, 2008 at 6:18 PM, Nishit Dave <stargazer.dave at gmail.com>wrote:

> Hi,
> I am trying to install the Roadmap application from
> http://www.onkelinx.com/qtopia.on.neo/?page_id=4 and on my Freerunner, and
> am following instructions given therein.  However, when I do this:
> tar -xvpf roadmap2.tgz
> I get an error message:
> tar: invalid tar magic.
> I have also tried it with tar -xvf roadmap2.tgz, but still the same result.
> I have tested the downloaded file with 7-zip and it seems to be OK.  I had
> read somewhere on a forum that the version of tar shipped by busybox
> (v1.16.1?) is broken.  Is that the case here?  Where can I find an unbroken
> version for Qtextended?

Further, the directory structure inside the roadmap2.tgz archive seems to
point to /media/mmcblk0p2, while my card is mounted at /media/card from
/dev/mmcblk0p1.  I tried to change the directory name inside the archive to
point it to /media/card, but it made no difference.

So there is a need to check if the version of tar included in qtextended
4.4.1 is indeed broken, and if the directory structure of the archive should
be corrected as well.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/community/attachments/20081009/ec51c7b1/attachment.htm 

More information about the community mailing list