[debian] State of annoying memory card corruption bug?

joakim at verona.se joakim at verona.se
Thu Oct 9 20:00:27 CEST 2008

Fox Mulder <Quakeman1 at gmx.net> writes:

> What do you mean by shut down "unexpectedly" ?
> The sd-card corruption patch which is in the recent kernels fixes the
> sd-bug when going into suspend and resume which isn't unexpected.

Ok, what I mean is that if the FR hangs for some reason, looses power or
whatever, I must powercycle it to reboot it. When this happens the
debian part of the sd card is unbootable.

I can then normally rescue it with "testdisk".

I dont think I ever even tried suspend/resume on debian.

> joakim at verona.se wrote:
>> Fox Mulder <Quakeman1 at gmx.net> writes:
>>> The kernel shipped with debian has the corruption bug.
>>> To update your kernel you must do it by hand. The instruction how to do
>>> this is in the debian page in the openmoko wiki [1].
>>> I changed my /boot partition from vfat to ext2 and symlink the
>>> boot-kernel to the one i want to use because i switch between the actual
>>> OM and FSO kernels.
>> I followed the instructions and installed a new kernel. I still get the
>> corruption bug whenever I shut down the FR unexpectedly.
>>> Ciao,
>>>      Rainer
>>> [1]
>>> http://wiki.openmoko.org/wiki/Debian#How_to_replace_the_default_kernel_with_a_recent_openmoko_kernel>>
>>> joakim at verona.se wrote:
>>>> Fox Mulder <Quakeman1 at gmx.net> writes:
>>>>> Which kernel and from when do you use?
>>>>> This bug should be fixed in newer kernels. But i still use the apm
>>>>> suspend/resume script which works for me since i installed debian.
>>>> Ok, how do I ensure I have a newer kernel? I just use the kernel shipped
>>>> with Debian, I think.
>>>>> Ciao,
>>>>>      Rainer
>>>>> joakim at verona.se wrote:
>>>>>> It is rather annoying to fix the memory card whenever it gets corrupted
>>>>>> and wont boot. I know there are workaround scripts, but they dont work
>>>>>> for me, since I most often get corruption after booting after unexpected
>>>>>> power down.
>>>>>> Is there any progress on this bug? Any working workarounds ?
Joakim Verona

More information about the community mailing list