USB networking problems with Ubuntu host (was RE: Default OM settings, no lan messed up)

Joel Newkirk freerunner at
Mon Oct 13 21:31:05 CEST 2008

On Mon, 13 Oct 2008 19:03:54 +0000, Matthias Camenzind
<m.camenzind at> wrote:

> Using 192.168.1.x for local network with internet acess and
> is my freerunner. I find no reason for this but sometimes internet acess
> from FR won't work, then I run firestarter (a firewall out of the ubuntu
> repositories) and internet works again (even if i shutdown firestarter).
> On freerunner ( is my router, is my host
> computer):
> auto usb0
> iface usb0 inet static
> 	address
> 	netmask
> 	network
> 	gateway
> 	up echo nameserver> /etc/resolv.conf
> On Host (Ubuntu):
> auto usb0
> iface usb0 inet static
>         address
>         netmask
>         post-up /etc/network/freerunner start
>         pre-down /etc/network/freerunner stop
> the /etc/network/freerunner script you can find in the wiki
> (USB_Networking in section "Ubuntu, Debian and others")

Is it possible that it's not working after reboot?  I'm wondering if
there's a DROP rule in the FORWARD chain of the hosts's firewall.  ("sudo
iptables -vnL FORWARD" shows Policy, rules, and packet/byte counts that
matched each - check it next time there's a problem BEFORE you run
firestarter, as well as "cat /proc/sys/net/ipv4/ip_forward" which should
return '1')

The simple fix in this scenario would probably be just to add these two
lines to the 'start' section of /etc/network/freerunner, based on what's in
the wiki:
iptables -I FORWARD -s -j ACCEPT
iptables -I FORWARD -d -j ACCEPT 

You can add the corresponding 'iptables -D' commands in the 'stop' section
to delete these rules if you like, but leaving them "laying around" is
pretty harmless.

I run Ubuntu on several workstations, three servers, and a bridge, with my
FR regularly connected to three of the above.  We'll make it work.


More information about the community mailing list