Problems with audio and usb-ethernet

Gunnar AAstrand Grimnes gunnar.grimnes at
Sun Oct 19 16:49:38 CEST 2008

Hi all,

I recently reflashed my freerunner to the 2008.09 release. At first
ethernet over usb worked fine, and I think also audio, but after running
"opkg upgrade" they both broke.

For usb-ethernet: Now nothing happens when I insert the usb-cable.
Flashing from uBoot still works fine though, and when booting into
debian on the sd card usb-ethernet works fine as well, so the problem is
somewhere with 2008.09 distro...

For audio: alsamixer reports:
"alsamixer: function snd_ctl_open failed for default: No such device"

Is audio and usb-ethernet meant to be provided by kernel modules?
lsmod shows me no modules loaded :(

also "modprobe -l" doesn't list sound or usb-ethernet modules.

(Nor does opkg list show me them as available to be installed)

Now to work around this I tried reflashing to the daily testing image,
there usb-networking works slightly better, i.e. the PC detects the
moko, but then something goes wrong and I cannot ssh. Also the settings
app is not shown in the launcher, nor is any other application I installed.

Thanks for any help!

- Gunnar

More information about the community mailing list