Echo issue on OM2008.08 solved

Alastair Johnson alastair at
Wed Oct 22 12:48:39 CEST 2008

Holger Freyther wrote:
> On Monday 13 October 2008 15:12:55 Daniel Nöthen wrote:
>> Hello,
>> I finally found a place in the qtopia sources where I could put code for
>> activating the
>> echo suppression for every incoming/outgoing call.
>> I'm quite sure that experienced qtopia programmers would find a better
>> place for it.
>> But this just works. And as long as no other solution is out there I
>> will share it
>> with other people who want to combat the echo.
> Sorry, I'm late to the party, tick applied a patch to Qtopia so I basicly just 
> want to understand.
> Why is sending this command only once not enough? Will it be reset after a 
> call? Any usage of alsactl should not have any influence on the modem itself.
> explanations welcome and thanks for scratching your itch.
> z.

My experience with FSO sending the command through mickeyterm was that 
once was enough, and the setting would remain over multiple calls. I 
wouldn't have tested over suspends though. After the initial patch to 
add %N0187 to the initialisation in qtopia based phone apps people 
started complaining that the echo was gone in the first call, but back 
in subsequent calls.

Since the AT command in question is undocumented we don't know what 
might reset it, or even if it's supposed to last over multiple calls. 
There is no known way to query the current setting either. This is one 
of the reasons I'm asking if we can have more documentation on this now 
the GSM firmware is being looked at again. Until someone manages to find 
out how it behaves, or is supposed to behave, setting echo suppression 
and noise reduction for every call seems to have a lot of gain for 
little cost.

More information about the community mailing list