Trouble adding uboot entry for debian

Martijn Otto martijntje at
Wed Oct 22 15:27:54 CEST 2008

Hello all,

I've just installed debian onto my SD-card. However, I am unable to
add a uboot entry. I am assuming i'm missing something basic and am
hoping for your input. I already tried the script,
and although it exits without an error, it does not add or modify any
entries in the uboot menu. I also tried to do it manually by accessing
the bootloader prompt, in which I issued the following commands:

setenv menu_2 Boot from microSD part2 (ext2+ext2): setenv bootargs
\${bootargs_base} rootfstype=ext2 root=/dev/mmcblk0p2 rootdelay=5
\${mtdparts} ro\; mmcinit\; ext2load mmc 1 0x32000000
\${sd_image_name}\; bootm 0x32000000
neo1973 power-off

With, of course, some printenv commands in between to verify the entry
does indeed show up. This all works as expected. I get a menu_2 entry
and the Freerunner powers down. However, when i go back into the uboot
menu, the entry does not show up and when i go into the console it is
gone too.

Does anybody have any idea what i'm doing wrong here?


More information about the community mailing list