Has anyone tried Qi?

Joel Newkirk freerunner at newkirk.us
Wed Oct 29 22:45:25 CET 2008

On Wed, 29 Oct 2008 14:58:34 -0600, Jason Cawood <jason at jasoncawood.com>
> Has anyone tried the new boot manager? or figured out how to install it?
> http://wiki.openmoko.org/wiki/Qi
> _______________________________________________
> Openmoko community mailing list
> community at lists.openmoko.org
> http://lists.openmoko.org/mailman/listinfo/community

Check the thread about 2.6.27 kernel.  I've been using qi off and on for a
couple weeks.

Plus side:
Faster.  approximately 30% faster, by the stopwatch, than uBoot.

Neg side: (note that these are of course fixable)
Sound doesn't currently work, period.  soundcard device not found.  With
SHR, FSO, 2008.x, Raster at least.
Often doesn't boot the first attempt after restoring power, needs second
'press and hold'
Often doesn't want to resume after suspend.

of note:
Backlight turns on right away, but screen remains blank until kernel load,
and kernel does NOT output gobs of text to the screen.
Will ALWAYS boot from uSD if first partition is ext2 and contains
/boot/uImage.bin, otherwise boots from NAND.
No splash screen. (not a problem, just be aware)

I altered /etc/init.d/banner to print an ascii openmoko logo, so there'd be
something more than 'please wait, booting' onscreen until X starts.

In short: Looks extremely promising, and once the soundcard bug is fixed I
will probably flash Qi and never look back.  Until soundcard and suspend
issues are addressed, I'd recommend it ONLY FOR TESTING.


More information about the community mailing list