illume-config-illume on 2008.8-updates

Carsten Haitzler (The Rasterman) raster at
Tue Sep 2 04:55:13 CEST 2008

On Tue, 2 Sep 2008 11:51:21 +1000 "Ben Batt" <benbatt at> babbled:

> On Tue, Sep 2, 2008 at 9:53 AM, The Rasterman Carsten Haitzler
> <raster at> wrote:
> > rm -rf ~/.e/e/config/illume
> Thank you Rasterman! I'm using the 20080901 rootfs, upgraded to the
> latest from the testing feed, and I couldn't get the wrench and
> keyboard to show. After doing the above, followed by "killall -HUP
> enlightenment", I now have the wrench, and I was able to turn on the
> keyboard! I had to turn off the Qtopia keyboard ("export
> QTOPIA_NO_VIRTUAL_KEYBOARD=1" in /etc/X11/Xsession.d/89qtopia) and
> restart X ("/etc/init.d/xserver-nodm restart") for it to work
> properly, but now it works! This is the first time I've been able to
> use the illume keyboard, and so far it's awesome!
> I actually suspected something like this would be the fix, so I tried
> removing the entire ~/.e directory yesterday, assuming it would be
> automatically regenerated, but I was sadly mistaken, and had to
> reflash the device :-P Let's hear it for making backups before you
> mess with important config files :-)

hmm - all of ~/.e should be re-filled if u nuke it. e's startup code does just
that. has done for years... thats how it gets there in the first place! :)

------------- Codito, ergo sum - "I code, therefore I am" --------------
The Rasterman (Carsten Haitzler)    raster at

More information about the community mailing list