qtopia update

Daniel Selinger slite at gmx.at
Tue Sep 2 13:03:32 CEST 2008

Ok, flashed the image 2 hours ago and did my first tests.

And i have to admit, this is by far the best image, in terms of phone
usability, my freerunner has seen so far ^^

1. Perfect suspend/resume behavior. No crashes or sleep forever
conditions so far.
2. Echo almost gone completely while still having loud voice.
(Just a very short echo when the other person stops speaking, like the
last letter of the last word)
3. No buzz at all, but i also had very few problems with this on the
other images.

Only 2 real issues found so far:

1. Every time i receive a call, after answering it, the phone
immediately shows another incoming call from the same person. This
doesn't interrupt the active call and 2 seconds later turns into an
unanswered call. The hangup button of the phonegui stays at "Answer".
So i have to do Options -> End to hang up.
On the other phone you hear the dialtone again for about 1 sec
immediately after answering the call on the FR. Maybe this has
something to do with that.

2. "No Network" "Searching for Network" messages still appear quite
often although the Network is up and FR can receiver calls and sms.

Bot things are not really bad and don't really harm functionality.

Maybe interesting too: 
Echo suppression didn't work on the first call after booting into
QTopia the first time. Echo was still there as before. On the next call
(maybe after the first suspend?) the echo was gone.
I'll do more tests on that in the evening. Hope i can reproduce that.

Interestingly Florian Hackenbergers patch for 2008.08 didn't work for
me at all. 

More information about the community mailing list