Freerunner won't charge, and won't start anymore due to out of power

Daniel Benoy daniel at
Tue Sep 2 21:26:07 CEST 2008

Yes I've experienced this too.  I have spare batteries so I experimented with completely draining my battery, and if you insert the charger, you'll probably hear a little noise out of the speaker, maybe feel it vibrate or see the LED blink, but it won't actually turn on because there's not enough power to operate the LCD monitor, but it still charges at 100mA and after a little while you should be able to boot it up, and have just enough power to reach the point in the kernel bootup where it instructs the PMU to draw full power.

If you're impatient, and you have a spare, you can hot swap the battery too.  Boot it up to the point where it starts drawing full power, then take out your full battery and put in a dead one.

On Tuesday 02 September 2008 11:58:28 Bastian Muck wrote:
> I had this problem, too. When it had this issue, i checked, if my
> laptop find a usb device, and it did. the freerunner stays in uboot,
> bis doesn't want to charge. but i have the impression, that it charges
> with 100mA. That is not enough for running it, but the battery is
> slowly charged, that after round about a half hour you can start it.
> Then it starts and charges again.
> Greetings Bastian
> Paul V. Borza schrieb:
> > I've flashed the updated 2008.8 on my Freerunner, and then left it
> > for a couple of days without turning on. Yesterday I've tried to
> > turn it on: it starts, the Openmoko logo appears, and then it
> > suddenly turns off.
> >
> > I think this is because of the battery that is already out of
> > power. However, I've tried connecting the Freerunner to the USB for
> > more than 12 hours, but the battery won't charge - or at least I
> > think it's not charging, because whenever I turn it on, the same
> > out of the blue shutdown happens.
> >
> > Has anyone got a similar behavior? Should/is the Neo charging when
> > is turned off and connected to the PC? I can't use it right now,
> > because it won't even boot, because during boot, it shuts down.
> >
> > Thanks.
> >
> > -- Paul V. Borza <>
> >
> > ----------------------------------------------------------------------
> >
> >
> > _______________________________________________ Openmoko community
> > mailing list community at
> >
> _______________________________________________
> Openmoko community mailing list
> community at

Daniel Benoy

More information about the community mailing list