Building and testing asu with MokoMakeFile and qemu

Nicola Mfb nicola.mfb at
Fri Sep 5 00:03:48 CEST 2008

I rebuilded all from scratch and now i found uImage-2.6.24.xxxx, so
make flash-qemu-local run successfull, howewer when i finally run make
run-qemu, u-boot loads the kernel and returns to it's main menu.

I'm not expert on u-boot, howewer i added -serial stdio to qemu, it gives:

U-Boot 1.3.2-moko12 (Sep  4 2008 - 17:27:20)

I2C:   ready
DRAM:  128 MB
NAND:  64 MiB
Found Environment offset in OOB..
Video: 640x480x8 31kHz 59Hz

NAND read: device 0 offset 0x244000, size 0x5000

Reading data from 0x248e00 -- 100% complete.
 20480 bytes read: OK
USB:   S3C2410 USB Deviced
In:    serial
Out:   serial
Err:   serial
neo_lcd_rst_switch: LCD reset.
jbt6k74_command: Display on.
neo_vib_switch: Buzz, buzz.
neo_vib_switch: Vibrator stopped.
neo_bl_switch: LCD Backlight now on.
GTA01Bv4 # boot
## Booting kernel from Legacy Image at 30100000 ...
   Image Name:   Openmoko/2.6.24+git1+a1e97c61125
   Created:      2008-09-04  13:37:58 UTC
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    1894664 Bytes =  1.8 MB
   Load Address: 30008000
   Entry Point:  30008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK
ERROR: image overwritten - must RESET the board to recover.
neo_gsm_switch: GSM disabled.

wath can i do now?


On 9/3/08, Nicola Mfb <nicola.mfb at> wrote:
> I'm working an ubuntu hh to build and test asu.
> I downloaded
> changed OM_GIT_BRANCH in org.openmoko.asu.stable
> after that i did make setup, make setup-machine-neo and make
> openmoko-qtopia-x11-image.
> The image was build successfull after several hours, but when i try to do
> make flash-qemu-local i get an error saying
> that is not possible to ls files in
> build/tmp/deploy/glibc/images/neo1973/uImage-2.6.*-om-gta01.bin
> What do i miss?
> thanks
>    Nicola

More information about the community mailing list