Wifi totally broken in Om2008.8?

Bryan DeLuca openmoko at bryandeluca.com
Sun Sep 7 05:39:07 CEST 2008

On Sat, 6 Sep 2008 17:13:26 +0200
"Daniel Hedblom" <daniel at solle.se> wrote:

> Im trying to get wifi going on my freerunner but i havent got any
> success yet at all. I have tried the various tips in the wiki but
> whatever i do packets seems to end up in the bit-bucket. Even as
> ifconfig shows packets going through eth0 both in and out nothing gets
> past the wireless driver when i check on the Wireless AP or on another
> computer with wireshark. Disabling usb0 and its default route havent
> helped. I regard myself as a pretty seasoned Linux user ( +10 years )
> but this phone has me beaten for now.
> I have also tried with Trolltechs Qtopia image and i have the same
> problem there. Am i fighting windmills, just plain thick or is my wifi
> nic in the phone perhaps broken?

I was having Wifi trouble under every distro until I remembered that I disabled 802.11G on my AP.  I'm pretty anal about how tightly configured my AP is, which can shoot you in the foot if you forget all the fancy stuff you setup months ago.   Looks like the FreeRunner radio only supports G.  After that I had no problem connecting with WPA2.

Hope this helps.
Bryan DeLuca <openmoko at bryandeluca.com>

More information about the community mailing list