I can no longer ssh into my FR via wifi

Rui Miguel Silva Seabra rms at 1407.org
Sun Sep 7 11:20:47 CEST 2008

On Sun, Sep 07, 2008 at 01:38:20PM +0800, William Kenworthy wrote:
> After a recent dropbear update I can no longer ssh into my FR via wifi.
> I still can login via usb0 and outgoing via wifi works fine.  Ive tried
> "ifdown usb0" (not necessary before), but with no change.
> Ive looked for config files and cant see anything relevant.
> Suggestions?

I hope you:
 * not using root for ssh
 * have added a new user for ssh
 * are using an RSA key
 * have a non blank/obvious password for root

One of the errors of dropbear's default installation is to listen on all
interfaces, and it was recently patched to bind to usb0's ip address by

Changing it is trivial for someone who knows how to do things with a
some security, all others should probably avoid doing it, or in time
we'll have OpenMokos remotely hackable.


Hail Eris, Hack GNU/Linux!
Today is Setting Orange, the 31st day of Bureaucracy in the YOLD 3174
+ No matter how much you do, you never do enough -- unknown
+ Whatever you do will be insignificant,
| but it is very important that you do it -- Gandhi
+ So let's do it...?

More information about the community mailing list