Does the GPS work on opentango.

roguemoko at roguemoko at
Tue Sep 9 09:07:53 CEST 2008

Robert William Hutton wrote:
> Orlando wrote:
>> I tried this... 
>> root at om-gta02:~# opkg list_installed | grep gpsd
>> gpsd-conf - 2.34-r9 -
>> root at om-gta02:~# opkg install gpsd
>> An error ocurred, return value: 2.
>> root at om-gta02:~# opkg install gps
>> An error ocurred, return value: 2.
>> root at om-gta02:~#
> I think "An error ocurred, return value: 2." roughly translates to "I 
> can't access the packages".  Have you checked that your network 
> connection works?  The usual reason for it not working is an empty 
> /etc/resolv.conf.  First you need to move the symbolic link to the 
> non-existent file out of the way:
> cd /etc
> mv resolv.conf resolv.conf.old
> Then you need to create a new /etc/resolv.conf file and put in some 
> nameserver lines so that DNS resolving works.  You can either install 
> dnsmasq on your desktop computer and then put:
> nameserver
> into your resolv.conf, or you can just copy the contents of the 
> resolv.conf from your desktop to your openmoko.

I'd say you are spot on, there's no connectivity to the internet. I'd 
recommend standard troubleshooting (nslookup/traceroute/ping) but it 
likely to be your resolv.conf.

udhcpc alters /var/run/resolv.conf ... so I wouldn't suggest removing 
the symlink, as a continually changing value should not be written to 
flash. I'd script something up to edit /var/run/resolv.conf or for now 
just change it manually. If you're not network hopping then 
/etc/resolv.conf is a viable alternative but be aware that you will be 
breaking typical embedded system operation, as in, other programs will 
be altering /var/run/resolv.conf when setting the network parameters ... 
well I hope :S


More information about the community mailing list