QtGps for Trolltechs Qtopia

Dareus dareus.persarumrex at gmail.com
Thu Sep 11 18:51:58 CEST 2008

Jim Morris wrote:
> Radek Barton( wrote:
>> 1. Download lastest gpsd source code at 
>> http://download.berlios.de/gpsd/gpsd-2.37.tar.gz and unpack it somewhere.
>> 2. Add line #include <linux/limits.h> to gpsd.h-head file.
>> 3. Modify line 15 of gps.h file from <limits.h> to <linux/limits.h>
>> 4. configure with command: PATH=/opt/toolchains/arm920t-eabi/bin:
>> $PATH ./configure --host=arm-angstrom-linux-gnueabi
>> 5. Then make, make install, etc.

I can confirm that the method works well, maybe you should add in your blog
post that libgps16, gps-utils and gpsd are needed.

Another issue: qtgps keeps on saying that there an 'error opening gpsd',
then i tried a low level access to gps, nothing worked (i already tried
before flashing and it worked well).
gps is power on
# gpspipe -r
gpspipe: could not connect to gpsd, Connection refused(111)

View this message in context: http://n2.nabble.com/QtGps-for-Trolltechs-Qtopia-tp777344p1083110.html
Sent from the Openmoko Community mailing list archive at Nabble.com.

More information about the community mailing list