QtGps for Trolltechs Qtopia

Jim Morris ml at e4net.com
Thu Sep 11 20:40:48 CEST 2008

Dareus wrote:
> Jim Morris wrote:
>> Radek Barton( wrote:
>>> 1. Download lastest gpsd source code at 
>>> http://download.berlios.de/gpsd/gpsd-2.37.tar.gz and unpack it somewhere.
>>> 2. Add line #include <linux/limits.h> to gpsd.h-head file.
>>> 3. Modify line 15 of gps.h file from <limits.h> to <linux/limits.h>
>>> 4. configure with command: PATH=/opt/toolchains/arm920t-eabi/bin:
>>> $PATH ./configure --host=arm-angstrom-linux-gnueabi
>>> 5. Then make, make install, etc.
> I can confirm that the method works well, maybe you should add in your blog
> post that libgps16, gps-utils and gpsd are needed.


> Another issue: qtgps keeps on saying that there an 'error opening gpsd',
> then i tried a low level access to gps, nothing worked (i already tried
> before flashing and it worked well).
> gps is power on
> # gpspipe -r
> gpspipe: could not connect to gpsd, Connection refused(111)

Make sure gpsd is instaled and running... > /etc/init.d/gpsd start
Also make sure there are no other gpsd daemons running hogging the serial port.

Jim Morris, http://blog.wolfman.com

More information about the community mailing list