SIP on Debian

Peter Schwenke peter at
Fri Sep 12 01:39:20 CEST 2008

Michael Shiloh wrote:
> Do you think the distortion was on the analog side e.g. volume settings, 
> or delays on the network side?

I tried again last night when I had a second person.  The distortion was
not too bad.  Gaps and missing chunks but promising.

But there was a long delay receiving the audio.  It might be networking
or processing speed.

> Were you using WiFi or Ethernet over USB?

Wifi on both ends with WPA2 encryption.

I'll will try it over Ethernet over USB and ethernet on the other end.

> Were you speaking to yourself on the other computer, so not over the 
> Internet?

Yes, locally.

I have tried and connected over the internet.  Wireless going out over a
512/512Kb ADSL line and connecting to  an actual Video Conferencing
endpoint another ADSL line.  I have 2 ADSL lines.

Doing the above with Ekiga *some* muffled distorted sounds go back and
forth.  I receive the picture from the endpoint.  But that stops
updating straight away.  Then sound stops.

Limiting the call to audio only, I have had both SIP and H239 calls with
Ekiga with the similar audio results.  Received audio clearly on the
FreeRunner for a while.  Muffled distorted hardly going out.  But after
a while  things don't well.  I've used Ekiga a fair bit but know it can
get dodgy over that ADSL line.

I have been able to initiate and receive calls calls using Linphone over
the Internet using the above gear.  But I have not managed to get audio
up and down.  I have also been unable to get audio up and down with my
laptop with Linphone so that problem is not only with the Openmoko.  I
have received the "no webcam image" from my laptop on the endpoint.
All the routing from the firewall on the laptop/Freerunner end should be
fine.  I have tried linphone with and without the firewall setting.

At some point I'm going to try setting the endpoint and phone up
together on the same local switch.  That will make it easier to work
where the problems are.

When I get (or build) a kernel with the uvcvideo driver I intend trying
 a webcam in usb host mode on the Freerunner and see what happens.


More information about the community mailing list