Duke Nukem 3D on Openmoko Neo

Risto H. Kurppa risto at kurppa.fi
Fri Sep 12 15:34:00 CEST 2008

>>> try to run it in 2007.2.
> I tried killing pulseaudio with no luck, see my other message in this
> thread.
> I changed the config file to turn off audio as suggested, and got a bit
> further, but still no luck:
> output:
> ---
> Checking sound inits.
> Checking music inits.
> RTS Manager Started.
>    Adding DUKE.RTS.
> Using .RTS file:DUKE.RTS
> Loading palette/lookups.
> ---
> at which point the screen goes black and nothing happens for more than 5
> minutes. I have to open up a new terminal window and kill the duke3d
> process to get anything to happen.
> could this be related to my accelerometer problems mentioned elsewhere
> (hexdump /dev/input/event2 and event3 gives me nothing)?

That's how far I get too, on 2007.2, sounds disabled (got exactly the
same errors also after killing pulseaudio)

It might have something to do with he accelerometers: sometimes they
still seem to fail after waking up from suspend. I'll try at some
point with a fresh-started phone and see if the accelerometers work
(with accelgame) and then see if duke works better.

Here's a .desktop -file for you to add to /usr/share/applications to
create a menu icon:

[Desktop Entry]
Name=Duke Nukem 3D
Comment=3D shooting

and create an executable file dukenukem3d in /usr/bin:

xrandr -s 240x320
xrandr -o 3
/media/card/duke3d/duke3d #MODIFY THIS TO SUIT YOUR INSTALL DIR!
#sorry, no idea if these will anymore fix the screen.. Any suggestions
and fixes are welcome!
xrandr -s 480x640
xrandr -o 3



More information about the community mailing list