Debian fso-gpsd problems [was Re: happy with debian]

Fox Mulder Quakeman1 at
Mon Sep 15 00:58:23 CEST 2008

arne anka wrote:
>> device to /dev/ttySAC1 and it works. I don't know for what reason i
>> should install fso-gpsd.
> so that you don't need gpsd.
> fso handles gps by itself -- thus having gpsd trying to handle gps too,  
> might end up in confusion.
> fso-gpsd is a compatibility layer between fso and applications requiring  
> gpsd.

As you meantioned the benefits from fso-gpsd i tried it out. First i
deinstalled gpsd and than installed fso-gpsd.
At the first look it seems to work. After starting tangogps it get a fix
quite fast (~8 satellites) and showed me my location.

But after a 1-2 minutes it suddenly stopped updating the location. I
tried it two times with the same result after a few minutes.
Another bug seems to be that the gps-time isn't delivered over fso-gpsd.
Tangogps always showed 1999-11-30 00:00.00 even with many satellites and
a good fix (while fso-gpsd still updates the coordinates).

To compare it i deinstalled fso-gpsd and reinstalled gpsd again and
tried the same. With gpsd i always get location updates even after quite
some time and the gps-time is also updated correctly like it should be.

So at the moment fso-gpsd is for me not really useable as replacement
for gpsd.

Did anybody else try fso-gpsd as replacement and did it work for him/her?


More information about the community mailing list