python-pyqt -- building against Qtopia in 2008.8

Kelvie Wong kelvie at
Tue Sep 16 08:16:43 CEST 2008

Over the past week (on and off), I have attempted to try and get PyQt working 
(as I feel it is the quickest way to get GUI apps up and running), but have 
run into some trouble.

First off, I have got PyQt (PyQt-4.3.3 linked against the Qt 4.4 libraries) 
working, but, of course, as the libraries are not already loaded, it is fairly 
slow to load the library.  I can share the opk/ipk files, if there's interest 
(and if anyone is interested in hosting them :).  This requires that qt4-x11-
free be installed, however; and the LD_LIBRARY_PATH must be set to search 
/usr/lib/ first so that it doesn't try to open the ones in /opt/Qtopia/ first 
and come up with undefined references.

However, this brought me to thinking, is there a way to build a version of 
PyQt against the qtopia libraries that are already installed? (the ones 
located in /opt/Qtopia)

I see that these are in a separate package (qtopia-phone-x11, I believe, 
rather than qtopia-core), and do not have an associated bbclass with them

Is this even a viable thing to attempt?  If at all possible, I would like to 
get PyQt working (well) on the Freerunner, and I am sure I am not the only 

(PS. is this the right list for these kind of questions?)
Kelvie Wong

More information about the community mailing list