Trolltech Qtopia (not X11) on 2008.8 base rootfs

Holger Freyther zecke at
Mon Sep 15 11:52:05 CEST 2008

On Wednesday 10 September 2008 00:13:36 Lorn Potter wrote:
> Cédric Berger wrote:
> > On Tue, Sep 9, 2008 at 23:09, Cédric Berger <cedric.berger74 at> 
> >> Ok thanks, this way I could get the error message :
> >>
> >> "qpe: error while loading shared libraries: cannot
> >> open shared object file: No such file or directory"
> >
> > So I just did an opkg install libstdc++6 and qpe could finally start:-)
> yes, g++ now has the silly notion that it needs to link libstdc++ to
> everything it compiles, even if it does not need it like Qt and Qtopia.
> There is a configure argument to turn off this silliness (when configuring
> g++), but I forget what it is. Some toolchains g++ automatically link in
> libstdc++ for 'you' and some do not. Any toolchain from OE will exhibit
> this behavior (since it is g++ default mode).

One can work around that by linking to -lsupc++ AND/OR using gcc as linker. 
Every now and then I go through OE and change c++ recipes to do that and the 
work is getting undone...


More information about the community mailing list