Qtopia and VOIP

Al Johnson openmoko at mazikeen.demon.co.uk
Thu Sep 18 02:45:41 CEST 2008

On Wednesday 17 September 2008, Marco Trevisan (Treviño) wrote:
> Al Johnson wrote:
> > On Wednesday 17 September 2008, Marco Trevisan (Treviño) wrote:
> >> Al Johnson wrote:
> >>> On Tuesday 16 September 2008, Nicola Mfb wrote:
> >>>> openmoko at asyring.homeip.net> wrote:
> >>>> What a pity!, it would be nice to have gsm/voip dialer integrated in
> >>>> the same application.
> >>>> Thanks Alex for the information, src/html tree should be cleaned :)
> >>>> Are there other voip clients suitable for the freerunner? (for x11
> >>>> too?)
> >>>
> >>> I've used the CLI version of linphone, but the GUI should be small
> >>> enough to fit in 480x640 too.
> >>
> >> Well, the 2.1.1 version of linphone works quite well (after editing a
> >> little the code) [1],
> >
> > That's great, partly for reasons I'll get to below. I'll scratch this
> > from my todo list then :-) What changes did you need to make? And do
> > youhave a bitbake recipe in OpenEmbedded yet?
> Well no... I'd have to say that I was never able to use the mokomakefile
> to get a working OE environment, that's way I've always used the
> Toolchain to compile. And also this time. So I could post just "bad
> ipkgs" here :P

Worked for me with 2007.2 but I've not tried with anything else yet. Probably 
time to give the FSO equivalent a try, and this should be as good a way as 
any to learn about bitbake.

> However I've not made many changes, just fixed some issues (like crash
> if there's no "sip:" text and automatic transformation from number to
> sip url [0123456789 => sip:0123456789 at voip.provider.net]) and added a
> brute alsa state changing. Then I'd like to change the interface to make
> it more usable in the moko (mostly the preferences should be fixed).

Would be good to see.

> >> however the problem is another: we miss the alsa
> >> states needed to use the phone speaker as default output device and the
> >> microphone as a capture device.
> >> This night I've played a lot with this software but I wasn't able to use
> >> it as a standard phone... :|
> >
> > The alsa state was relatively simple to set up - so much so that I don't
> > think I saved it. There has been at least one state file for voip posted
> > to the list though, and I think there is one in FSO milestone 3.
> Well, yesterday was too late, but I didn't test the file (coming from om
> packages) voip-handset.state.
> I've tested it, but it simply set the volume of the main speaker to a
> lower value; it doesn't route the audio output to the phone headset
> speaker (the one we generally use to hear a call!).
> Was you able to do so? If you did it, how?

If that's all that's wrong with it then turn down the speaker (Control 
3: "Headphone Playback Volume") and turn up the earpiece (Control 4: "Speaker 
Playback Volume")

> I've not found any other working state file.

Doesn't look like I've got it saved anywhere. I'll try to make another one but 
it might take a few days to get everything in place.

> > The bit that caused problems was the audio interface. I was using 2007.2
> > so I killed pulseaudio to start with. The default alsa interface uses
> > dmix, and linphone complained that this didn't allow a duplex connection.
> > I could hear things on the Neo, but the other end couldn't hear me. I
> > changed the .linphonerc to use OSS for the mic instead of alsa:
> >
> > [sound]
> > playback_dev_id=ALSA: default device
> > ringer_dev_id=ALSA: default device
> > capture_dev_id=OSS: /dev/dsp
> My default linphone configuration was that of using only OSS. I've not
> tested if a called person was hearing me, however.
> > This gave me a fully functional CLI linphone, except for needing to
> > switch state files to get the ring on the speaker and the call in the
> > earpiece. Echo was present as expected, and I didn't try enabling
> > linphone's echo cancellation.
> That is inusable... It uses too much CPU I guess, since enabing it I
> can't hear the called people as expected.

:-( Looks like I'll have to have another play with the Wolfson noise gate 

> > The reason I'm glad you've got >=1.7 running is that hooks for external
> > control of linphone were included in that version. I've seen this working
> > in yeaphone [2] and the code seemed fairly simple. If this is available
> > in the GUI version it may give us a way to quickly add alsa state
> > changing. It also gives us a relatively easy way to use linphone as a SIP
> > backend for the FSO telephony interface.
> Yes I guess it could be but it should be include dbus support before :P,
> (it has not support for it, if I'm not wrong).

It wasn't using dbus in 1.7 and I don't think it's been added since, but I may 
have missed something. I'll have a look at the current state of linphone and 
the FSO telephony interface.

> I've also to say that the first linphone version I got running in my
> freerunner was the unstable 2.9.9. It was a little more hard to compile
> it, but the new glade interface is too sophisticated for a so small device.
> Bye

More information about the community mailing list