VoIP on Freerunner working properly (using linphone and SIP)

"Marco Trevisan (Treviño)" mail at 3v1n0.net
Fri Sep 19 03:33:59 CEST 2008

Brian Code wrote:
> Initial testing of this had the audio routed properly through the
> earpiece and good audio from the microphone. There was some echo on the
> non-Freerunner side, and on initial connection, a bit of a beeping
> sound. Otherwise, it's a go. Linphone uses only about 10-12% CPU (was
> using a PCM codec). Sound was decent to a cell phone in Canada using a
> Wifi connected Freerunner based in Costa Rica. 
> cd /etc/ 
> wget http://www.koolu.org/asound.conf
> wget http://www.koolu.org/voip-handset.state
> alsactl -f voip-handset.state restore (This step required to set proper
> audio parameters). 

Well... As you maybe read, I got a sip calling working also using the
gtk interface of linphone [1] (I've just to release the packages I've
built) but the problems that I've stated in the "Qtopia Voip" thread
rests using these alsa configuration and state files :(.

Using them with linphone 2.1.1 gtk I always hear the voice in the
speaker and not in the earpiece. I've set in the configuration the Alsa
default interface as my sound device and I've tried both your alsa
states and configs and the ones provided by Openmoko.
But in no case I get the sound in my earpiece.
Now, I've changed some configuration parameters of my linphone build and
using Alsa I can get the sound also in the earpiece, but at this point
I can't disable at all the main speaker. :|

I'll try the packages you've suggested, but this seems so strange to me
since the alsa configuration should be the same for us.

[1] http://lists.openmoko.org/pipermail/community/2008-September/030735.html

Treviño's World - Life and Linux

More information about the community mailing list