Dima Kogan dkogan at
Mon Sep 22 05:28:22 CEST 2008

As Andy said in another post, there are some kernel patches coming to
fix this. I have much better luck after I apply this patch:;a=commit;h=c0a2797d7ba8f6e07187794ccd2664ca3209b613

This isn't in the stable kernel tree yet, so Andy's still working on it
presumably, but if you want something NOW, this may fix your woes.

On Sun, 21 Sep 2008 23:07:00 -0400
Joel Newkirk <freerunner at> wrote:

> well, I flashed as follows, both rootfs and kernel from each:
> testing-om-gta02-20080921, 'base/empty' - seems a bit TOO empty, as I
> was unable to establish any USBnet communications with it.
> So I flashed to 2008.9 'stable' - accelerometers dead.
> Tried 2008.8-update - accelerometers dead.
> Tried 2008.08.08 - same deadness.  Getting worried now - this one
> surely would have worked if it were a software matter...
> Tried 2008.4 - turns out it didn't offer sysfs access to
> accelerometers.
> Back to 2008.9 - still no joy.
> each reboot, it seems, the output from the accelerometers is slightly
> different, although each time each axis registers within the range of
> -5 to +12, and remains unchanged until the Freerunner is powered down.
> Then I checked again under 2008.9 (fresh flash) at ten minutes uptime,
> after composing this message, and suddenly both are reading dynamic
> data again!!  I'm happy, but now I'm thoroughly confused, and
> somewhat worried as to what could have caused this in the first
> place...  (as well as irritated that I went through 6 complete
> reflashes before it reached a working state again, something like 6
> hours wasted and nothing learned)
> j

More information about the community mailing list