Dale Maggee antisol at internode.on.net
Mon Sep 22 05:48:52 CEST 2008

Christian Adams wrote:
> Hash: SHA1
> moinmoin,
> did anyone manage to get the usb-gadget g_file_storage to work properly?
> for me it's no problem to do:
> ifconfig usb0 down
> rmmod cdc-ether
> rmmod g_ether
> modprobe g_file_storage file=<...>
> but what - at least for me - not works is:
> rmmod g_file_storage (modprobe -r g_file_storage)
> the shell i run this command in completely freezes and the module  
> gets not unloaded
> ciao,
>   morlac
I see this problem if I try to switch to file storage mode from a 
script. If I run the commands from a terminal it works fine, but if i 
run it from a script it totally freezes the freerunner.

I've also had limited success connecting it to machines in file storage 
 - Connected to my fedora box just fine, automounted, and popped up a 
nautilus window showing SD card contents
 - Connected to my mate's mac, and saw nothing at all
 - Connected to my mate's windoze box, and the device was detected as a 
USB storage device, but the drive didn't show up for some reason. I even 
looked in 'disk management' and it doesn't show up as a drive, so it's 
not a problem with partitions as far as I can tell.

Before anybody asks, yes, my SD card is formatted as Fat32, not ext2:
        Device Boot      Start         End      Blocks  Id System
/dev/mmcblk0p1              43       81821     7973376   b Win95 FAT32

I've found the best way to switch back to usb ethernet mode is to do it 
the windows way: reboot!

More information about the community mailing list