[debian & gps] How to check gps

Fox Mulder Quakeman1 at gmx.net
Wed Sep 24 11:08:43 CEST 2008

-stacy wrote:
> Fox Mulder wrote:
>> For me fso-gpsd didn't work right so i changed back to gpsd and
>> everything works like a charm with gps. :)
>> Maybe you try installing gpsd and deinstall fso-gpsd.
> When you say "everything works like a charm" do you mean "everything"?
> Does Zhone's location test app work? I would be very surprised if it
> does. However, if the only applications you care about work with gpsd,
> this is definitely an option.

To be fair i must say i just use tangogps and navit at the moment. I
never tried "Location" because i don't see any benefit against tangogps.

I don't know what exactly was the problem why fso-gpsd doesn't work
right. I was running gpsd since installation of debian without problems.
Than at some point in time Joachim Breitner announced fso-gpsd as
replacement for gpsd in this ML. I tried it by deinstalling gpsd and
installing fso-gpsd and nothing more (maybe i was missing something?).
After that i activated gps and started tangogps and i get a fix for the
position. But after that i see that the gps-time wasn't correct. It was
stuck at 1999-11-30 00:00.00 even with a fix and ~8 satellites. And than
after about 1-2 minutes the output from fso-gpsd stops and no more
position updates were recieved by tangogps. I have do deactivate gps and
reactivate it to get output for the next few minutes again.
I tried it several times and it was always the same behaviour. After
that i deinstalled fso-gpsd and reinstalled gpsd and everything (fix,
time) works again even after quite some time.

At the moment i only use gpsd because of the trouble fso-gpsd gave me.
But maybe someone could say what i did wrong so i get it to work with
fso-gpsd. :)


More information about the community mailing list