[FSO] How to develop with Qt

Nicola Mfb nicola.mfb at gmail.com
Sat Sep 27 17:13:18 CEST 2008

On Fri, Sep 26, 2008 at 6:22 PM, Kelvie Wong <kelvie at ieee.org> wrote:

> In the meantime, I've managed to get PyQt4 working (hooked up against
> Qt-x11);
> this eliminates the need for a toolchain (or even building apps in
> general).
> There's another thread about that on this list.
> --
> Kelvie Wong

That's very nice, Kelvie.
I'm still trying to get a working and safe oetree with qt library inside :).
The first time i tried with the org.openembedded.dev branch and my typical
angstrom configured local.conf file, but it got a compilation error on
uicmoc4-native. After that i tried with the fso openmoko conf file, it
failed again but i noted that the preferred version of qt4 there was 4.3.3
instead of 4.4.1. I remembered that in org.openembedded.stable there was
4.3.3 version, so i tried again with the stable branch. It compiled fine but
did not create all the requested ipk (empty). I managed a bit on the
qt_packaging.inc recipie and finally i got a working qt-oe-tree, i was able
to compile a my application too. I bitbaked the last fso unstable image and
flashed the phone with it, setupped a fake feed server on my oe tree, added
it to feeds on the phone and did opkg update, opkg install qt4-x11-free,
opkg install my-application, and after that i was able to start it adding a
simple DISPLAY=:0.
But i'm not very happy of this as it's not simple and i do not like to mix
different branches.
Please share your experience on this...


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/community/attachments/20080927/4654c3bb/attachment.htm 

More information about the community mailing list