[Debian/gta02v5] zhone suspend not working anymore

Fox Mulder Quakeman1 at gmx.net
Mon Sep 29 16:52:48 CEST 2008

Since over a week suspend isn't working anymore for me.
I use the latest fso kernel [1] and latest updates for debian until 29.9.08.
When i take a look at the zhone.log file everything seems to be fine.
After pressing the power button for 1 sec my neo goes into sleep [2].
But than i can't wake it up anymore. Pressing the power button does
nothing at all. But suspend was working fine a short while ago. So maybe
the actual kernel or some updates did break it.
I tried to wake it up with calling my neo and it rings at the callers
end but nothing happens at my neo. The only way to get it back is to
remove the battery and reboot it.

After that i tried it with the latest om kernel and suspend/resume works
what was really surprising. But the behaviour when calling the neo when
in suspend is also quite surprising. The neo wakes up and it rings and
vibrates but zhone doesn't show any caller. After about 30 seconds zhone
displays the caller and accept/reject buttons. But pressing any of these
buttons does nothing. Even after the caller hung up my neo was happily
going on with the ringing and vibrating. Only fso-frameworkd restart
stopt the ringtone but not the vibrating. :)

This is quite some strange thing i experienced with the latest kernels
and zhone. Is there any way to make suspend/resume and phoning work



2008-09-29 13:48:41,047 INFO INPUT EVENT = POWER, pressed, 0
2008-09-29 13:48:42,022 INFO INPUT EVENT = POWER, held, 1
2008-09-29 13:48:42,078 INFO INPUT EVENT = POWER, released, 0
2008-09-29 13:48:42,405 INFO ENTERING SUSPEND

More information about the community mailing list