[2008.9] Wifi very unreliable

Alastair Johnson alastair at truebox.co.uk
Tue Sep 30 13:30:17 CEST 2008

Alex Osborne wrote:
> Matthias Apitz wrote:
>>  I'm trying to bring up the eth0 with
>> # ifup eth0
>> this works very unreliable; in (let's say) 8 of 10 cases it can't
>> associate to the AP, even not after fresh re-boots and independently if
>> the AP at my home works with WEP or in my office with WPA;
> I found that with wpa_supplicant there was a problem with disconnecting 
> from an AP.  The essid would apparantly not get cleared properly on the 
> card (although iwconfig would show it as cleared) and until you manually 
> cleared it, wpa_supplicant would just sit in a loop trying to connect 
> and getting authentication timeouts.  You can see these message if you 
> run wpa_cli.  I worked around it by adding a pre-up that clears the essid:
> allow-hotplug eth0
> iface eth0 inet manual
>   wpa-driver wext
>   wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
>   pre-up iwconfig eth0 essid off
> iface default inet dhcp
> iface home inet dhcp
> This seems to work reliably for me except that I still have to ifdown 
> and ifup when I move to a different AP.  So if manually connecting with 
> iwconfig works for you, you could try same workaround. Here's what my 
> wpa_supplicant.conf looks like:
> ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
> network={
>     ssid="XXXXXXX"
>     key_mgmt=NONE
>     wep_tx_keyidx=0
>     id_str="home"
> }
> network={
>     key_mgmt=NONE
> }
> Note that this is with Debian, not 2008.9 -- I'm not sure whether 
> Om2008.9 supports exactly the same /etc/network/interfaces syntax as Debian.

2007.2 was missing some of the scripts (and more?) needed to support 
wpa-roam when I tried it. Haven't checked in 2008.x yet. The news about 
essid is interesting though.

More information about the community mailing list