[2008.9] Wifi very unreliable

William Kenworthy billk at iinet.net.au
Tue Sep 30 14:52:14 CEST 2008

On Tue, 2008-09-30 at 14:37 +0200, Matthias Apitz wrote:
> El día Tuesday, September 30, 2008 a las 08:11:48PM +1000, Alex Osborne escribió:
> > Matthias Apitz wrote:
> > > I'm trying to bring up the eth0 with
> > >
> > ># ifup eth0
> > >
> > 
> ...
> 	matthias

Hi Matthias, I am using these scripts with the unmodified Om 2008.9
system successfully to connect to a linksys wrt150 running wpa.  The
only caveat is that the FR has a good signal when connecting.  Turn on
wifi using the settings dialog first - dont select anything else.  Same
with mofi etc - if you have used them, reboot first.  Then you should be
able to connect/reconnect at will.  It seems that some of the background
apps are reluctant to let go of the connection.

myth1 root # cat wap

# Turn on wifi at the settings dialog first!

ifdown eth0
iwconfig eth0 txpower auto channel 1
killall wpa_supplicant
killall udhcp
wpa_supplicant -ieth0 -c/etc/wpa_supplicant/wpa_supplicant.conf -B ;
ifup eth0


myth1 root # cat nowap

ifdown eth0
killall wpa_supplicant
iwconfig eth0 txpower off

William Kenworthy <billk at iinet.net.au>
Home in Perth!

More information about the community mailing list