Linphone not available?

yacine yacine.k at
Thu Apr 2 21:11:46 CEST 2009

On Friday 20 March 2009, yacine wrote:
> Al Johnson wrote:
> >
> >
> > I think I got all the deps that aren't in the main repos, but may have
> > missed
> > some. Looks like faulty memory about the 2.x version - these 1.6 but
> > includes
> > the patch to allow external control by yeaphone etc. There is no gui
> > IIRC, so
> > you'll be using linphonec.
> >
> > The binaries can be built by following the standard SHR build
> > instructions,
> > then:
> > 	cd shr-testing
> > 	. setup-env
> > 	bitbake linphone
> >
> > As for the new version, I want to try it first. The daemon mode was
> > mentioned
> > in the release email, but I haven't seen exactly what it does. If it
> > looks nice I'll try to make a bitbake recipe, but it'll be my first for
> > an app.
> Thank you for taking time to do this. From what you have said I guess I
> have to put SHR.

It'll probably work with other OE-based distros like FSO and 2008.x too, so 
give it a try first unless you want to try SHR anyway.

btw 3.1.0 now builds, but I've not tested it yet.

Openmoko community mailing list
community at


I just wanted to say thank you for provided the packages. Using them I was able to install linphonec v1.6
My problem now is the voice path. 
I have created a free sip account from I tested the account using a PC sip client and it worked just fine. 

The problem occurs when I try to use the same sip account on the OM and call the echo number I get this: 

warning: Unknown nb_ctl request:  12
ortp-error-Could not set vbr mode to speex encoder.
warning: Unknown nb_ctl request:  34

Also, before making the call I get:
Registration on sucessful.

I followed instructions in here . 

I also tried testing my microphone and speakers with voicenote . It worked. 

Any help of course is appreciated. 


View this message in context:
Sent from the Openmoko Community mailing list archive at

More information about the community mailing list