Tasks Client for FR

KaZeR kazer at altern.org
Fri Apr 10 15:35:05 CEST 2009

try the apps by knj - there's a google calendar app (should be adding
other backends later), and an e-mail client, with support for imap


Thanks for the hint. I tried it under shr :
First problem : 
>root at om-gta02 /opt/knjmokocalendar $ knjmokocalendar 
>-sh: knjmokocalendar: not found

In fact the launcher starts with bash shebang, instead of sh

Then i faced a couple of missing dependency :
- knjrbfw
- libsqlite3-ruby1.8
- libglade2-ruby1.8,

At this point, i was able to run ./knjmokocalendar.rb (but still not using the shortcut).
I set up my login/pass, and ics url.

Tried to sync, i had to install ruby1.8-googlecalendar and ruby1.8-openssl.
ruby1.8-openssl needs libssl0.9.7, when on shr-unstable you have libssl0.9.8. Let's try with --nodeps, and  ln -s /usr/lib/libssl.so.0.9.8 /usr/lib/libssl.so.0.9.7 and ln -s /usr/lib/libcrypto.so.0.9.8 /usr/lib/libcrypto.so.0.9.7. I also had to install  ruby1.8-rexml.

Now it seems fine, excepted that i have a name resolution error. Probably not related to the app itself.

View this message in context: http://n2.nabble.com/Tasks-Client-for-FR-tp2609094p2616238.html
Sent from the Openmoko Community mailing list archive at Nabble.com.

More information about the community mailing list