Tasks Client for FR

Robin Paulson robin.paulson at gmail.com
Sat Apr 11 00:02:44 CEST 2009

2009/4/11 KaZeR <kazer at altern.org>:
> Thanks for the hint. I tried it under shr :
> First problem :
>>root at om-gta02 /opt/knjmokocalendar $ knjmokocalendar
>>-sh: knjmokocalendar: not found
> In fact the launcher starts with bash shebang, instead of sh


> Then i faced a couple of missing dependency :
> - knjrbfw
> - libsqlite3-ruby1.8
> - libglade2-ruby1.8,

they're listed here: http://www.opkg.org/package_166.html - should
really be in the ipk for the file, but it's still very alpha

> At this point, i was able to run ./knjmokocalendar.rb (but still not using the shortcut).
> I set up my login/pass, and ics url.

yeah, there is a bug with one of the files not set to execute. chmod +
x fixed that for me

> Tried to sync, i had to install ruby1.8-googlecalendar and ruby1.8-openssl.
> ruby1.8-openssl needs libssl0.9.7, when on shr-unstable you have libssl0.9.8. Let's try with --nodeps, and  ln -s /usr/lib/libssl.so.0.9.8 /usr/lib/libssl.so.0.9.7 and ln -s /usr/lib/libcrypto.so.0.9.8 /usr/lib/libcrypto.so.0.9.7. I also had to install  ruby1.8-rexml.

hmm, more dep issues. it will work, takes a bit of fiddling first

> Now it seems fine, excepted that i have a name resolution error. Probably not related to the app itself.

More information about the community mailing list